Openjudge Zipper

Zipper

总时间限制:
1000ms
内存限制:
65536kB
描述
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.

输入
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

输出
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

样例输入
3
cat tree tcraete
cat tree catrtee
cat tree cttaree
样例输出
Data set 1: yes
Data set 2: yes
Data set 3: no
来源
Pacific Northwest 2004

继续动规:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char A[205],B[205],C[420];
bool judge(int endA,int endB,int endC){
    //递归基
    if(endC>=0){
        if(endA>=0&&A[endA]==C[endC]&&judge(endA-1,endB,endC-1)||endB>=0&&B[endB]==C[endC]&&judge(endA,endB-1,endC-1)){
            return true;
        }else return false;
    }else if(endA==-1&&endB==-1&&endC==-1)return true;
    else return false;
}
int main(){
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%s %s %s",A,B,C);
        bool flag=judge(strlen(A)-1,strlen(B)-1,strlen(C)-1);
        printf("Data set %d: %s\n",i,(flag?"yes":"no"));
    }
}

发表回复

您的电子邮箱地址不会被公开。 必填项已用 * 标注